Back to overview
Downtime

PSA service outage has been noticed in US East servers

Feb 5, 2024 at 9:05am UTC
Affected services
Production PSA

Resolved
Feb 5, 2024 at 9:08am UTC

Outage has been resolved.

Created
Feb 5, 2024 at 9:05am UTC

PSA service outage has been noticed in US East servers